Debian

Installing PHP 5.3.3 from packages on Debian Lenny with apc, xdebug, memcache etc

Building apache and PHP with all its extensions may be fun once or twice but it is a major pain in the neck. So to avoid that (and to have it before Debian Squeeze is released) you can use e special dotdeb repository of almost everything that you may need as a web dev. It is especially convenient if you have a few development servers to update with different configurations and you don't want to waste too much time on it.

Upgrade Debian Etch to Lenny

Debian is my favorite linux system since 2001 or 2002. It is awesome.

The only thing that could be better is that packages are usually very old comparing to current versions. Well but at least everything works. I have used apt-get to upgrade distributions since potato release. So far it worked every time. I think i had some small issues with upgrading samba or cups once but simply going back to previous version worked of the package worked. But after all it always worked.

Instalacja apache i php4 pod Debianem

W większości przypadków na serverach polecałbym dystrybucję stable a na desktopach wersję testing. Wtedy instalujemy wszystko z pakietów binarnych. Jednak nieraz nie sa one wystarczająco aktualne wtedy mozemy sięgnąć po instalację ze źródeł.

Syndicate content

About the author

Artur Ejsmont

Hi, my name is Artur Ejsmont,
welcome to my blog. I am a passionate software engineer living in Sydney and working for Yahoo!

Web Scalability for Startup Engineers

If you are into technology, you can order my book Web Scalability for Startup Engineers on Amazon. I would love to hear what are your thoughts so please feel free to drop me a line or leave a comment.

Follow my RSS